INSTALLING AND UPDATING

Mac Installation
Windows Installation
Activating Your License
Updating


Mac Installation

 

On Mac, the installation should be very easy by using the included installer.

  1. Close LIGHTROOM
  2. Unzip your download
  3. Control + Click on the installer app NegativeLabPro-OSX.app, and select OPEN
  4. You may see an “unkown developer” warning. Select Open Anyway (if you don’t see that option, make sure you “Control + Clicked” the installer)
  5. The installer will then automatically do three things: 1) Add the Negative Lab plugin to a folder, 2) Add the Negative Lab RAW camera profiles and Vuescan Profiles to Lightroom, and 3) Setup the Negative Lab shortcut key for you CTRL + N
  6. Restart Lightroom, Go to File -> Plug-in Manager
  7. In the Plugin-manager, select “add”, then select the NegativeLabPro.lrplugin file, and click Add Plug-in
  8. If you’ve purchased a license, you can add it now in the Plug-in Manager. Otherwise, you can continue to use your 12 free trial shots.
  9. If you’re on Lightroom 6, you’ll need to turn off graphics processing. To do this, go to “Preferences > Performance” and un-check the “Use Graphics Processor” option. (If you are using Lightroom Classic, you can leave Graphics Processing turned on)

Windows Installation

 

On windows, there is not an automatic installer, but it is pretty easy to install manually.

  1. Unzip your download
  2. Open Lightroom (if it is not open)
  3. In Lightroom, got to “Edit -> Preferences” and select the “Preset” tab
  4. Click “Show Lightroom Presets Folder”
  5. In the explorer window that opens, navigate to the “CameraRaw\CameraProfiles” folder.
  6. Copy the entire folder “NegativeLab Camera Profiles” (from your unzipped download) into this CameraProfiles folder.
  7. If planning on using Vuescan RAW DNGs, copy the “Vuescan Profiles” folder, also into the “CameraRaw\CameraProfiles” folder.
  8. Next, copy the “NegativeLabPro.lrplugin” folder into a folder that is easy to navigate to and you won’t accidentally delete later. IMPORTANT!!! - You must place the “NegativeLabPro.lrplugin” on the same drive as Lightroom, and you need to have full read/write access to the folder. Also, make sure there are NO special characters anywhere in the path to the plugin folder (especially relevant to users with accents in their name). If any of the above conditions aren’t met, some of the tools in Negative Lab Pro will fail. The safest place to put the folder is directly on the root of your main drive (like C:)
  9. Back in Lightroom, go to “file -> Plug-in Manager”
  10. In the Plug-in Manager, select “Add” then navigate to the folder were you copied your NegativeLabPro.lrplugin
  11. Single-click the “NegativeLabPro.lrplugin” folder, and click “Select Folder” (be sure to select the whole folder, and not a file within it).
  12. If you’ve purchased a license, you can add it now in the Plug-in Manager. Otherwise, you can continue to use your 12 free trial shots.
  13. RESTART LIGHTROOM - you must restart Lightroom after this (otherwise, the camera profiles will not load properly).
  14. IMPORTANT: Make sure to TURN OFF the “Use Graphics Processor” option in Lightroom if it is enabled. To do this, go to “Preferences > Performance” and un-check the “Use Graphics Processor” option.

Windows HOTKEY Installation

 

  1. Inside the unzipped download, navigate to the Hotkey folder
  2. Double-click “NegativeLabHotkey.exe”
  3. If you get a message that “Windows Protected Your PC,” click “More Info” and then click “Run Anyway”. If you have other anti-virus software running that prevents it from working, you may need to add the hotkey program to your anti-virus software “whitelist” - how you do this will depend on the anti-virus software you run.
  4. The Hotkey will now be running the background. To see where it is running, go to the “show hidden icons” container in the bottom right hand corner of Windows.
  5. In Lightroom, you can now use the Hotkey to bring up Negative Lab Pro. The hotkey for you will depend on the language you have set Lightroom to in your preferences.

WINDOWS HOTKEYS BY LANGUAGE:

English: Ctrl - Alt - N
German: Ctrl - Alt - N
Swedish - Ctrl - Alt - N
Netherlands: Alt + N
French: Ctrl + Alt + X
Italian: Alt + Shift + X
Portugese - Alt + X
Spanish - Alt + X

GETTING THE WINDOWS HOTKEY TO LAUNCH ON STARTUP

Since the hotkey is a program, by default, it will stop whenever you restart your computer. If you want it to automatically run without having to relaunch after each startup, here is what to do:

  1. Hit Windows key + R to bring up the “run” dialog
  2. Type “shell:startup” and hit enter
  3. Copy the “NegativeLabHotkey.exe” file into this folder.

CUSTOMIZING THE WINDOWS HOTKEY

If you’d like to change the hotkey (or add to an existing AutoHotKey setup), I’ve included the script for you. Even if you are new to AutoHotKey, it is possible to customize the script to meet your needs.

  1. Download and install AutoHotKey free from https://www.autohotkey.com/
  2. Right-click on the “NegativeLabHotkey.ahk” file, and choose to open with NotePad
  3. Inside the ahk file are further instructions for how to edit to meet your needs

Activating Your License

If you’ve purchased a license for Negative Lab Pro, you can now activate it to unlock full use of Negative Lab Pro.

Here’s how to activate your license:

  1. Make sure you are connected to the Internet
  2. In Lightroom, go to File > Plug-in Manager
  3. Copy the licence from your receipt email, and add it to the field beside the key symbol ()
  4. Then hit the ACTIVATE button.
  5. You should then see a confirmation that the key has been accepted!

Troubleshooting License Keys:

“I can’t find my license”
Follow these instructions to find your license key.

404 Error
Check and make sure that you are copy/pasting directly from your email receipt, and make sure there are no extra spaces at the end of your license.

Could Not Connect to the Internet
Make sure you are connected to the internet and any firewalls or internet blocking apps (like LittleSnitch) are turned off. In some countries (like China), you will need to use a VPN to activate because China blocks traffic.

Out of Uses For License Key
There is a limit to the number of times NLP can be activated to protect from theft. If you reach this error, please email at nate@natephotographic.com so I can restore your license.

After getting a confirmation of the new license, it reverts back to trial
In some cases, the license may get dropped from your system. If this happens, it will go back to trial mode. Just follow the activation steps again to reactivate your license.


Updating

When new updates are available, they will be emailed to you. Follow the instructions in the email to download.

  1. Exit Lightroom (it hangs on to the old plugin if it’s still running).
  2. Download and unzip the latest package
  3. On Mac, just run the new installer package (remember, you will need to “Control + Click” the installer app, select “Open” and then “Open Anyway”)
  4. On Windows, move the new plugin into the same directory as the old version (overwriting the old version). If the update includes Camera Profiles or Presets that you need, follow the installation instructions to add them to the indicated directories.
  5. Restart Lightroom

More help for updating Negative Lab Pro can be found here.